#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\.[^.\n]{2,}+)\1+$"
Local $sString = "gmail.com.com.com" & @CRLF & _
"gmail.com.com.org" & @CRLF & _
"gmail.tv.tv" & @CRLF & _
"alongrepetitionlongrepetition" & @CRLF & _
"shortrepetitionon" & @CRLF & _
"gmail.bonbon" & @CRLF & _
"gmail.bonbon.bonbon"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)