import re
regex = re.compile(r"(\.[^.\n]{2,}+)\1+$", flags=re.MULTILINE)
test_str = ("gmail.com.com.com\n"
"gmail.com.com.org\n"
"gmail.tv.tv\n"
"alongrepetitionlongrepetition\n"
"shortrepetitionon\n"
"gmail.bonbon\n"
"gmail.bonbon.bonbon")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)