re = /(\.[^.\n]{2,}+)\1+$/m
str = 'gmail.com.com.com
gmail.com.com.org
gmail.tv.tv
alongrepetitionlongrepetition
shortrepetitionon
gmail.bonbon
gmail.bonbon.bonbon'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result