use strict;
my $str = 'gmail.com.com.com
gmail.com.com.org
gmail.tv.tv
alongrepetitionlongrepetition
shortrepetitionon
gmail.bonbon
gmail.bonbon.bonbon';
my $regex = qr/(\.[^.\n]{2,}+)\1+$/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";