const regex = /(\.[^.\n]{2,}+)\1+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\.[^.\\n]{2,}+)\\1+$', 'gm')
const str = `gmail.com.com.com
gmail.com.com.org
gmail.tv.tv
alongrepetitionlongrepetition
shortrepetitionon
gmail.bonbon
gmail.bonbon.bonbon`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);