using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\.[^.\n]{2,}+)\1+$";
string substitution = @"$1";
string input = @"gmail.com.com.com
gmail.com.com.org
gmail.tv.tv
alongrepetitionlongrepetition
shortrepetitionon
gmail.bonbon
gmail.bonbon.bonbon";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}