using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\bthickness(?:\s{1,10}(?!(?:after|myectomy|resection)\b)[a-zA-Z]{1,100}){0,8}\s{0,10}[:=(]?)\d{1,3}(?:\.\d{1,3})?";
string input = @"maximum size of thickness in base to mid of anteroseptal wall(1.7cm)
(anterolateral and inferoseptal wall thickness:1.6cm)
hypertrophy in apical segments maximom thickness=1.6cm with sparing of posterior wall
septal thickness=1cm
LV apical segments with maximal thickness 1.7 cm and dynamic
septal thickness after myectomy=1cm ";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}