import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\bthickness(?:\\s{1,10}(?!(?:after|myectomy|resection)\\b)[a-zA-Z]{1,100}){0,8}\\s{0,10}[:=(]?)\\d{1,3}(?:\\.\\d{1,3})?";
final String string = "maximum size of thickness in base to mid of anteroseptal wall(1.7cm) \n"
+ "(anterolateral and inferoseptal wall thickness:1.6cm) \n"
+ "hypertrophy in apical segments maximom thickness=1.6cm with sparing of posterior wall\n"
+ "septal thickness=1cm \n"
+ "LV apical segments with maximal thickness 1.7 cm and dynamic \n"
+ "septal thickness after myectomy=1cm ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}