const regex = /(?<=\bthickness(?:\s{1,10}(?!(?:after|myectomy|resection)\b)[a-zA-Z]{1,100}){0,8}\s{0,10}[:=(]?)\d{1,3}(?:\.\d{1,3})?/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\bthickness(?:\\s{1,10}(?!(?:after|myectomy|resection)\\b)[a-zA-Z]{1,100}){0,8}\\s{0,10}[:=(]?)\\d{1,3}(?:\\.\\d{1,3})?', 'gmi')
const str = `maximum size of thickness in base to mid of anteroseptal wall(1.7cm)
(anterolateral and inferoseptal wall thickness:1.6cm)
hypertrophy in apical segments maximom thickness=1.6cm with sparing of posterior wall
septal thickness=1cm
LV apical segments with maximal thickness 1.7 cm and dynamic
septal thickness after myectomy=1cm `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}