$re = '/(?<=\bthickness(?:\s{1,10}(?!(?:after|myectomy|resection)\b)[a-zA-Z]{1,100}){0,8}\s{0,10}[:=(]?)\d{1,3}(?:\.\d{1,3})?/mi';
$str = 'maximum size of thickness in base to mid of anteroseptal wall(1.7cm)
(anterolateral and inferoseptal wall thickness:1.6cm)
hypertrophy in apical segments maximom thickness=1.6cm with sparing of posterior wall
septal thickness=1cm
LV apical segments with maximal thickness 1.7 cm and dynamic
septal thickness after myectomy=1cm ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);