import Foundation
let pattern = #"(?<=\bthickness(?:\s{1,10}(?!(?:after|myectomy|resection)\b)[a-zA-Z]{1,100}){0,8}\s{0,10}[:=(]?)\d{1,3}(?:\.\d{1,3})?"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
maximum size of thickness in base to mid of anteroseptal wall(1.7cm)
(anterolateral and inferoseptal wall thickness:1.6cm)
hypertrophy in apical segments maximom thickness=1.6cm with sparing of posterior wall
septal thickness=1cm
LV apical segments with maximal thickness 1.7 cm and dynamic
septal thickness after myectomy=1cm
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)