import re
regex = re.compile(r"(?<=\bthickness(?:\s{1,10}(?!(?:after|myectomy|resection)\b)[a-zA-Z]{1,100}){0,8}\s{0,10}[:=(]?)\d{1,3}(?:\.\d{1,3})?", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("maximum size of thickness in base to mid of anteroseptal wall(1.7cm) \n"
"(anterolateral and inferoseptal wall thickness:1.6cm) \n"
"hypertrophy in apical segments maximom thickness=1.6cm with sparing of posterior wall\n"
"septal thickness=1cm \n"
"LV apical segments with maximal thickness 1.7 cm and dynamic \n"
"septal thickness after myectomy=1cm ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")