package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*(Dock_1:)\s*\[(.*)\].*`)
var str = `Dock_1: [UNUSED]
Dock_2: [UNUSED]
Dock_3: [UNUSED]
#This must be typed in the display block that detect the dock point is used
[REPLACEALL].*(Dock_1:)\s*\[(.*)\][WITH]Dock_1: [USED]
#This must be typed in the display block that detect the dock point is unused
[REPLACEALL].*(Dock_1:)\s*\[(.*)\][WITH]Dock_1: [UNUSED]`
var substitution = "Dock_1: [USED]"
fmt.Println(re.ReplaceAllString(str, substitution))
}