// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m).*(Dock_1:)\s*\[(.*)\].*").unwrap();
let string = "Dock_1: [UNUSED]
Dock_2: [UNUSED]
Dock_3: [UNUSED]
#This must be typed in the display block that detect the dock point is used
[REPLACEALL].*(Dock_1:)\\s*\\[(.*)\\][WITH]Dock_1: [USED]
#This must be typed in the display block that detect the dock point is unused
[REPLACEALL].*(Dock_1:)\\s*\\[(.*)\\][WITH]Dock_1: [UNUSED]";
let substitution = "Dock_1: [USED]";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}