const regex = /.*(Dock_1:)\s*\[(.*)\].*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*(Dock_1:)\\s*\\[(.*)\\].*', 'gm')
const str = `Dock_1: [UNUSED]
Dock_2: [UNUSED]
Dock_3: [UNUSED]
#This must be typed in the display block that detect the dock point is used
[REPLACEALL].*(Dock_1:)\\s*\\[(.*)\\][WITH]Dock_1: [USED]
#This must be typed in the display block that detect the dock point is unused
[REPLACEALL].*(Dock_1:)\\s*\\[(.*)\\][WITH]Dock_1: [UNUSED]`;
const subst = `Dock_1: [USED]`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);