import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*(Dock_1:)\\s*\\[(.*)\\].*";
final String string = "Dock_1: [UNUSED]\n"
+ "Dock_2: [UNUSED]\n"
+ "Dock_3: [UNUSED]\n\n"
+ "#This must be typed in the display block that detect the dock point is used\n"
+ "[REPLACEALL].*(Dock_1:)\\s*\\[(.*)\\][WITH]Dock_1: [USED]\n\n"
+ "#This must be typed in the display block that detect the dock point is unused\n"
+ "[REPLACEALL].*(Dock_1:)\\s*\\[(.*)\\][WITH]Dock_1: [UNUSED]";
final String subst = "Dock_1: [USED]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}