use strict;
my $str = 'Dock_1: [UNUSED]
Dock_2: [UNUSED]
Dock_3: [UNUSED]
#This must be typed in the display block that detect the dock point is used
[REPLACEALL].*(Dock_1:)\\s*\\[(.*)\\][WITH]Dock_1: [USED]
#This must be typed in the display block that detect the dock point is unused
[REPLACEALL].*(Dock_1:)\\s*\\[(.*)\\][WITH]Dock_1: [UNUSED]';
my $regex = qr/.*(Dock_1:)\s*\[(.*)\].*/mp;
my $subst = 'Dock_1: [USED]';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";