import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([A-F0-9]{2})";
final String string = "DE, FF, 00, CD, 00, 00, \"?\", CE, DE, AB, \"?\", \"?\", \"?\"";
final String subst = "0x$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}