import Foundation
let pattern = #"([A-F0-9]{2})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"DE, FF, 00, CD, 00, 00, "?", CE, DE, AB, "?", "?", "?""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"0x$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)