const regex = /([A-F0-9]{2})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([A-F0-9]{2})', 'gm')
const str = `DE, FF, 00, CD, 00, 00, "?", CE, DE, AB, "?", "?", "?"`;
const subst = `0x$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);