re = /([A-F0-9]{2})/m
str = 'DE, FF, 00, CD, 00, 00, "?", CE, DE, AB, "?", "?", "?"'
subst = '0x$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result