$re = '/([A-F0-9]{2})/m';
$str = 'DE, FF, 00, CD, 00, 00, "?", CE, DE, AB, "?", "?", "?"';
$subst = "0x$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;