import re
regex = re.compile(r"([A-F0-9]{2})", flags=re.MULTILINE)
test_str = "DE, FF, 00, CD, 00, 00, \"?\", CE, DE, AB, \"?\", \"?\", \"?\""
subst = "0x$1"
result = regex.sub(subst, test_str)
if result:
print(result)