# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\.(?!(?:com|org|net)\b)/?/gm;t' <<< "An example of a website would be google.com or similar. However this is not what we are looking for"