#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\.(?!(?:com|org|net)\b)"
Local $sString = "An example of a website would be google.com or similar. However this is not what we are looking for"
Local $sSubst = "?"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)