$re = '/\.(?!(?:com|org|net)\b)/m';
$str = 'An example of a website would be google.com or similar. However this is not what we are looking for';
$subst = "?";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;