using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\.(?!(?:com|org|net)\b)";
string substitution = @"?";
string input = @"An example of a website would be google.com or similar. However this is not what we are looking for";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}