const regex = /\.(?!(?:com|org|net)\b)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\.(?!(?:com|org|net)\\b)', 'gm')
const str = `An example of a website would be google.com or similar. However this is not what we are looking for`;
const subst = `?`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);