re = /\.(?!(?:com|org|net)\b)/m
str = 'An example of a website would be google.com or similar. However this is not what we are looking for'
subst = '?'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result