using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(a|A)rray(\.<.+>)?$|^(.+)\[\]$";
string input = @"// should match this
Array
array
Array.<SomeRandomType>
array.<SomeOtherRandomTypeName>
someCustomType[]
// should not match this
ArRay
arrAY
Array<String>
string[Array]
[]
Array.
Array.<>
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}