package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(a|A)rray(\.<.+>)?$|^(.+)\[\]$`)
var str = `// should match this
Array
array
Array.<SomeRandomType>
array.<SomeOtherRandomTypeName>
someCustomType[]
// should not match this
ArRay
arrAY
Array<String>
string[Array]
[]
Array.
Array.<>
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}