$re = '/^(a|A)rray(\.<.+>)?$|^(.+)\[\]$/m';
$str = '// should match this
Array
array
Array.<SomeRandomType>
array.<SomeOtherRandomTypeName>
someCustomType[]
// should not match this
ArRay
arrAY
Array<String>
string[Array]
[]
Array.
Array.<>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);