import Foundation
let pattern = #"^(a|A)rray(\.<.+>)?$|^(.+)\[\]$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
// should match this
Array
array
Array.<SomeRandomType>
array.<SomeOtherRandomTypeName>
someCustomType[]
// should not match this
ArRay
arrAY
Array<String>
string[Array]
[]
Array.
Array.<>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)