const regex = /^(a|A)rray(\.<.+>)?$|^(.+)\[\]$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(a|A)rray(\\.<.+>)?$|^(.+)\\[\\]$', 'gm')
const str = `// should match this
Array
array
Array.<SomeRandomType>
array.<SomeOtherRandomTypeName>
someCustomType[]
// should not match this
ArRay
arrAY
Array<String>
string[Array]
[]
Array.
Array.<>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}