import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(a|A)rray(\\.<.+>)?$|^(.+)\\[\\]$";
final String string = "// should match this\n"
+ "Array\n"
+ "array\n"
+ "Array.<SomeRandomType>\n"
+ "array.<SomeOtherRandomTypeName>\n"
+ "someCustomType[]\n\n"
+ "// should not match this\n"
+ "ArRay\n"
+ "arrAY\n"
+ "Array<String>\n"
+ "string[Array]\n"
+ "[]\n"
+ "Array.\n"
+ "Array.<>\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}