#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:\b|_)ELLs?(?=\b|_)"
Local $sString = "ELL" & @CRLF & _
"ELLs" & @CRLF & _
"The ELL" & @CRLF & _
"Which ELLs" & @CRLF & _
"ELLs or _ELLs" & @CRLF & _
"However I also get following outputs" & @CRLF & _
"" & @CRLF & _
"Ellis Island" & @CRLF & _
"Bellis"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")