const regex = /(?:\b|_)ELLs?(?=\b|_)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\b|_)ELLs?(?=\\b|_)', 'gm')
const str = `ELL
ELLs
The ELL
Which ELLs
ELLs or _ELLs
However I also get following outputs
Ellis Island
Bellis`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}