re = /(?:\b|_)ELLs?(?=\b|_)/m
str = 'ELL
ELLs
The ELL
Which ELLs
ELLs or _ELLs
However I also get following outputs
Ellis Island
Bellis'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end