$re = '/(?:\b|_)ELLs?(?=\b|_)/m';
$str = 'ELL
ELLs
The ELL
Which ELLs
ELLs or _ELLs
However I also get following outputs
Ellis Island
Bellis';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);