using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\b|_)ELLs?(?=\b|_)";
string input = @"ELL
ELLs
The ELL
Which ELLs
ELLs or _ELLs
However I also get following outputs
Ellis Island
Bellis";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}