# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(^\s*)#\s(.*)$/$1$2/gm;t' <<< "parent:
A:
name: foo
value: x.y.z # check=something
# value: \"yay\" # check=nothing
B:
name: bar
value: p.q.r # check=something
# value: \"yay\" # check=nothing"