package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^\s*)#\s(.*)$`)
var str = `parent:
A:
name: foo
value: x.y.z # check=something
# value: "yay" # check=nothing
B:
name: bar
value: p.q.r # check=something
# value: "yay" # check=nothing`
var substitution = "$1$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}