# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<!,|\s)\s*\n//gm;t' <<< "Line One,
Line Two
Line Three
Line Four,
Line Five"