$re = '/(?<!,|\s)\s*\n/m';
$str = 'Line One,
Line Two
Line Three
Line Four,
Line Five';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;