const regex = new RegExp('(?<!,|\\s)\\s*\\n', 'gm')
const str = `Line One,
Line Two
Line Three
Line Four,
Line Five`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);