use strict;
my $str = 'Line One,
Line Two
Line Three
Line Four,
Line Five';
my $regex = qr/(?<!,|\s)\s*\n/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";