re = /(?<!,|\s)\s*\n/m
str = 'Line One,
Line Two
Line Three
Line Four,
Line Five'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result