package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\{[^}]*\bname="(.*?)"[^}]*\}`)
var str = `{name="certbot.service", state="failed"}`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}