re = /\{[^}]*\bname="(.*?)"[^}]*\}/m
str = '{name="certbot.service", state="failed"}'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result