const regex = /\{[^}]*\bname="(.*?)"[^}]*\}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\{[^}]*\\bname="(.*?)"[^}]*\\}', 'gm')
const str = `{name="certbot.service", state="failed"}`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);